Problem a: A+B for Input-Output Practice (I)

Problem a: A+B for Input-Output Practice (I)

Time Limit: 1 Sec  Memory Limit: 64 MB
Submit: 545  Solved: 389
[Submit] [Status] [Web Board] [Creator:]

Description

Your task is to Calculate a + b. Too easy?! Of course! I specially designed the problem for acm beginners. You must have found that some problems have the same titles with this one, yes, all these problems were designed for the same aim

Input

The input will consist of a series of pairs of integers a and b, separated by a space, one pair of integers per line.

Output

For each pair of input integers a and b you should output the sum of a and b in one line, and with one line of output for each line in input.

Sample Input Copy

1 5
10 20

Sample Output Copy

6
30

HINT

这是一个求两数之和的题目,输入多对用空格分开的两个数a b,输出a+b的和,每一对数据的和占一行。编写代码时需要注意的是,由于没有指出有多少对输入数据,因此我们可以编写如下代码:

//C语言

#include <stdio.h>//把main函数定义成int类型
int main() 
{ 
    int a,b; 
    //输入结束时,scanf函数返回值为EOF,即没有数据输入时则退出while循环 
    while(scanf("%d %d",&a, &b) != EOF) 
        printf("%d\n",a+b); 
    return 0; //返回值为0 
}

//C++语言

#include <iostream>
using namespace std;
//把main函数定义成int类型
int main() 
{ 
    int a,b; 
    //输入结束时 
    while(cin >> a >> b) 
        cout << a + b << endl; 
    return 0; //返回值为0 
} 

//Python语言

while True:
    a, b = map(int, input().split())
    print(a+b)